Основы работы в 3D редакторе SketchUP. Часть 1

Материал из robbo
Ошибка создания миниатюры: Не удаётся сохранить эскиз по месту назначения

Захаров Леонид Сергеевич

Основы работы в 3D редакторе SketchUP. Часть 1

В предыдущих статьях мы приступили к рассмотрению возможностей 3D редакторов применительно к созданию деталей для моделей роботов, был приведен пример создания моделей деталей в редакторе FreeCAD:

Основы работы в 3D редакторе FreeCAD. Часть 1. Основы работы в 3D редактореFreeCAD. Часть 2.

Теперь приступим к изучению возможностей 3D редактора SketchUP Make. Скачать можно здесь. После установки запускаем программу.

• В правом верхнем углу нажимаем кнопку «Choose Template»,

• в открывшемся окне выбираем «3DPrinting– Millimeters»,

• в нижнем углу нажимаем «StartusingSketchUp».

После запуска программы в центре рабочего поля выделим мышкой и удалим изображение ограничительного куба — он не потребуется, зная размеры детали и возможности принтера, можно обойтись без него.

Сохранять файлы в формате 3DS, подходящем для 3D печати, в SketchUP можно лишь в течение ограниченного периода, однако можно установить плагин, с помощью которого без труда файлы экспортируются в формат STL, а также в формат DXF, который необходим для нарезки деталей на станке ЧПУ. Скачать плагин можно с сайта http://www.guitar-list.com, в разделе Download - Convert SketchUp SKP files to DXF or STL размещен файл skp_to_dxf.rbz. После установки и перезагрузки программы, плагин появится в меню Tools.

Теперь настроим рабочий стол в удобном для нас виде:

• в меню программы выберем wiev-toolbars

• в открывшемся окне снимем «галочки» напротив всех строчек, поставим напротив Large Tool Set, закроем окно кнопкой Close

• в меню выберем Window – Model Info

• в открывшемся окне слева выберем Units

• настроим в соответствии с картинкой (рис 1)

Ошибка создания миниатюры: Не удаётся сохранить эскиз по месту назначения

Основные инструменты, которые будут использованы для создания моделей деталей, отмечены на следующем рисунке (рис 2).

Ошибка создания миниатюры: Не удаётся сохранить эскиз по месту назначения

Начнем с инструмента «выделение». С помощью этого инструмента можно выделять части чертежа. Кликом левой кнопки мыши (ЛКМ) выделяется один элемент, движением мыши с нажатой ЛКМ: • слева-направо — только элементы, оказавшиеся полностью в зоне выделения • справа-налево — все элементы, которые хотя бы частично попали в зону выделения. Переключаться на выделение можно также нажатием клавиши «пробел».

«Блок навигации» -здесь располагаются кнопки перемещения по рабочему полю, масштабирования отображения, вращения. Однако пользоваться удобнее клавишами мыши (рис 3):

Ошибка создания миниатюры: Не удаётся сохранить эскиз по месту назначения

Как видно, вращение и сдвиг тут не так, как во FreeCAD расположены, а наоборот. Можно подвигать, потренироваться.

В редакторе есть возможность переключать стандартные виды в меню Camera-StandardViews. В работе будем пользоваться, в основном изометрическим видом — Iso. Кроме того, если перемещение по чертежу заведет в ситуацию, когда потеряется ориентация в пространстве, можно просто выбрать в меню этот вид и все вернется к удобоваримому отображению.

Еще одна особенность — изометрия рисунка может искажать его реальный вид и при отображении нельзя доверять глазам, нужно проверять только измерением.

Следующий важный инструмент - «Рулетка» С помощью этого инструмента можно ставить размерные точки, измерять расстояния, но самая главная функция — установка направляющих. Ну и еще важное замечание, отмена изменений — Ctrl Z. Вернуть Ctrl Y. Или в меню Edit.

В процессе обучения будем создавать модели деталей для того же самого робота, что и в статье о FreeCAD, причем две детали создадим те же самые, чтобы можно было сравнить методы и возможности.

Ошибка создания миниатюры: Не удаётся сохранить эскиз по месту назначения

Нарисуем цилиндрическую проставку, Для тренировки воспользуемся «Рулеткой» и установим направляющие, которые дадут в своем пересечении центр окружности:

• выберем «Рулетку»

• дважды кликнем по каждой из осей — X и Y, на них появились направляющие

• кликнем по оси Y, но не в центре координат (только кликнем, удерживать не надо) и двинем мышь вдоль оси Х (красной). За курсором будет двигаться направляющая (рис 4). О том, что движение действительно происходит вдоль оси, подскажет красный цвет линии (1)

• не нажимая кнопок мыши, введем расстояние в миллиметрах, например 10. Это число, показывающее расстояние от оси до направляющей, отобразится в окошке размеров в правом нижнем углу окна программы (2)

• нажмем на клавиатуре Enter, направляющая установлена.

• поставим еще одну направляющую, теперь вдоль оси Х, отодвинув ее от оси на те же 10 мм.

Ошибка создания миниатюры: Не удаётся сохранить эскиз по месту назначения

Если направляющая «не вытягивается», значит вы переключили режим «Рулетки».Переключиться обратно можно двойным кликом ЛКМ рулеткой на пустом поле чертежа (у курсора-рулетки должен быть маленький "+")

Нарисуем окружность:

• установим удобный масштаб и отображение и выберем инструмент «Окружность»

• подвигаем мышью в районе пересечения направляющих, добившись, чтобы на пересечении появился красный крестик

• кликнем ЛКМ в точку пересечения направляющих. Красный крестик говорит о том, что это точное пересечение направляющих. При моделировании нужно за этим четко следить.

• двинем мышь в сторону и обратим внимание, чтобы цвет появляющейся окружности был синим — это значит, что окружность перпендикулярна синей оси — Z.

• не нажимая кнопок мыши, введем с клавиатуры радиус окружности 4мм (он также отобразится в размерном окошке справа внизу окна программы) и нажмем Enter(рис 5).

Ошибка создания миниатюры: Не удаётся сохранить эскиз по месту назначения

Нарисуем еще одну окружность, радиусом 1,7мм из той же точки. Здесь нужно заметить, что с Numpad десятичную запятую вводить бесполезно, приходится вводить eё в английской раскладке с клавиатуры. Как видите, на самом деле это не окружности, а круги, то есть поверхности.

Включим инструмент «Выделение» и выделим мышью площадь внутри меньшей окружности (рис 6).

Ошибка создания миниатюры: Не удаётся сохранить эскиз по месту назначения

Удалим ее с помощью Delete, получилось кольцо. Выделим кольцо (рис 7).

Ошибка создания миниатюры: Не удаётся сохранить эскиз по месту назначения

• Выберем инструмент «Вытягивание».

• Кликнем ЛКМ на получившееся кольцо и двинем мышь немного вверх.

• Введем высоту, на которую надо вытянуть деталь, 22мм

• Нажмем Enter (рис 8).

• Деталь готова, теперь проект нужно сохранить.

Ошибка создания миниатюры: Не удаётся сохранить эскиз по месту назначения

Далее экспортируем деталь в формат STL:

• Выберем в меню Edit-Delete Guides и удалим направляющие. • Выберем в меню Edit-Select Al. • Выберем в меню Tools-Export to DXF or STL. • В открывшемся окне выберем единицы измерения — миллиметры, нажмем ОК. • В открывшемся окне выберем формат STL, нажмем ОК. • Сохраним файл.

Моделирование шаровой опоры.

Тут очень хорошо видно различие между приемами в редакторах. В SketchUP нет простых параметрических фигур. Поэтому «круглые» объемные объекты нужно создавать методом вращения плоских фигур. Есть еще один нюанс. При вращении мелких фигур могут происходить ошибки, появляться незакрытые объекты, поэтому мы построим модель в масштабе 10:1, а потом уменьшим ее в 10 раз. Итак, откроем редактор, подготовим рабочий стол, удалив «коробку» и установив единицы измерения (см. первый рисунок статьи).

Предварительно несколько дополнительных сведений об окружности. В этом редакторе стандартная окружность на самом деле представляет собой 24-х угольник, т.е. состоит из 24-х отрезков. Когда мы создавали проставку, этот вопрос не был таким важным, потому что диаметр был небольшим, да и форма тоже не была важна. Теперь же мы будем моделировать шаровую опору, и тут уже важно, чтобы она внутри была максимально круглая. Чтобы изменить количество отрезков, нужно выбрать инструмент «окружность», кликнуть в точку, которая будет центром, двинуть мышь в сторону, вписать нужный радиус, нажать Enter, тут же ввести количество отрезков с буквой «s» на конце, например, 96s, и нажать Enter.

Нарисуем окружность радиусом 115мм на плоскости XY (цвет ее должен быть синим во время постройки):

• выберем инструмент «окружность»

• кликнем в центр координат

• двинем мышь в сторону

• впишем радиус 115мм, нажмем Enter

• впишем 96s, нажмем Enter

Теперь нарисуем 2 окружности из центра координат в плоскости XZ.Одну радиусом 99мм, другую 115мм. Окружность во время рисования должна быть зеленого цвета. Если будут возникать проблемы, то нужно повернуть деталь поудобнее, или воспользоваться стандартными видами Camera-StandardViews (рис10).

Ошибка создания миниатюры: Не удаётся сохранить эскиз по месту назначения

Построим 2 направляющих параллельно оси Х. Одну вверх на 105мм, вторую вниз на 60мм (рис 11).

Построим 2 отрезка (хорды) по направляющим (рис12):

• Выберем инструмент «Линия».

• Кликнем на пересечении окружности с направляющей с одной стороны, затем с другой. Не забывайте о том, что прежде, чем кликнуть мышью, установить начало или конец отрезка, нужно добиться, чтобы в точке пересечения появился красный крестик. При необходимости увеличить масштаб. Если не соблюдать этого правила, фигуры могут оказаться незамкнутыми.

• Построим также отрезок по оси Z от хорды до внутренней окружности в верхней части рисунка.

• Теперь переключимся на «выделение», выделим и удалим плоскость, оставив лишь линию окружности, а также удалим лишние линии и сегменты. Можно для удаления линий воспользоваться «Ластиком», зажав ЛКМ и стерев линии (рис 13).

Теперь построим объемную фигуру с помощью инструмента «Cледуй за мной»:

• выделим горизонтальную окружность

• выберем инструмент «следуй за мной»

• кликнем по плоской фигуре, которую будем вращать.

Редактор может ненадолго задуматься, затем нарисует фигуру вращения (рис 14). Инструмент «следуй за мной» может создавать объемные фигуры, двигая их вдоль любой выделенной линии. В данном случае — вокруг окружности. Получившийся объект должен быть белого цвета. Если поверхности серые, значит «объект вывернут наизнанку». Внутренние поверхности имеют серо-голубой цвет, а наружные — белый. Чтобы перевернуть поверхность, нужно кликнуть на ней ПКМ и выбратьReverse Faces.

Ошибка создания миниатюры: Не удаётся сохранить эскиз по месту назначения

• Построим две направляющие параллельно оси Х, на 40мм от нее, и две параллельно оси Y на 165мм от нее. (Размеры я установил для удобства отображения) (рис 15).

• Соединим точки пересечения линиями(рис 16).

• Выберем инструмент «Дуга по 2 точкам» (рис 17)

• Кликнем сначала на один угол прямоугольника, затем на другой, двинем мышь вдоль оси Х, пока не появится надпись Half Circle (половина окружности), кликнем еще раз

• Нарисуем такую же дугу с другой стороны.

• Выделим и удалим линии в основаниях дуг (рис 18).

Ошибка создания миниатюры: Не удаётся сохранить эскиз по месту назначения

Нарисуем 2 окружности радиусом 17мм, удалим «серединки» (рис 19)

• выберем инструмент «вытягивание»

• кликнем по плоскости

• двинем мышь вверх

• впишем расстояние 75мм

• повторим с другой стороны (рис 20)

• соединим линиями углы (рис 21), проемы закрылись плоскостями

• удалим«Ластиком» лишние линии (рис 22)

Ошибка создания миниатюры: Не удаётся сохранить эскиз по месту назначения

Повернем объект так, чтобы было видно снизу.

• Вытянем плоскости вниз на 40мм (рис 23)

• Точно так же соединим углы линиями (рис 24)

• Лишние линии удалим (рис 25).

Некоторые поверхности не пересекаются, хотя и проходят друг через друга. Визуально это заметно, когда нет линии в углах.

Чтобы сделать объект общим, нужно выделить непересекающиеся плоскости, зажав Ctrl (рис 26), затем кликнуть ПКМ по выделенной области, выбрать из контекстного меню Intersect Faces – With Selection – создание пересечения граней. Теперь можно посмотреть на объект снизу и удалить все лишнее изнутри (рис 27). Нужно следить, чтобы не удалилось что-то снаружи. Если это произошло - возможно вы не разделили какие-нибудь плоскости.

Теперь заглянем внутрь. Для этого кликнем по поверхности ПКМ и выберем Hide - сделаем грань невидимой (рис 29).

Ошибка создания миниатюры: Не удаётся сохранить эскиз по месту назначения

Внутри тела ничего лишнего быть не должно, а тут, как видно, есть плоскости и линии. Удалим их (рис 30).

Чтобы вернуть видимость поверхности, выберем в меню программы Edit – Unhide – All

Посмотрим на объект снизу, проведем хорду, отверстие в окружности закроется (рис 31).

• Построим 2 направляющих: Кликнем «рулеткой» по имеющимся направляющим, обозначавшим ранее центр окружности, и опустим вниз параллельно осям. Теперь они опять отмечают точкой пересечения центр окружности (рис 31).

• Удалим теперь хорду и построим шестигранник радиусом 35мм. Поверхность внутри окружности тоже удалим (рис 32).

• Выберем инструмент «Вытягивание» и утопим посадочное место под гайку внутрь на 25мм. Кликнув по поверхности, двинем внутрь, впишем 25 (рис 33).

• То же самое сделаем с другой стороны.

Деталь в целом готова, теперь надо разделить ее на 2 половины:

• Удалим направляющие, которые нам больше не понадобятся, чтобы избежать путаницы и отложим от осей новые.

• По четырем точкам пересечения построим прямоугольник с помощью инструмента «Прямоугольник» или инструмента «Линия» (рис 34).

Теперь создадим пересечение нашего объекта с прямоугольником:

• Нужно выделить поверхности, через которые проходит прямоугольник,

• выделить сам прямоугольник, зажав Ctrl,

• кликнуть ПКМ по выделенной области,

• выбрать из контекстного меню Intersect Faces – With Selection. Эту операцию можно делать в несколько приемов. Не забудьте поверхности внутри отверстий и внутри шара.

• Теперь удалим ненужные направляющие, поверхности внутри отверстий и шара (рис 35).

Сохраним проект.

Ошибка создания миниатюры: Не удаётся сохранить эскиз по месту назначения

Теперь осталось удалить одну половинку и сохранить проект под другим именем, затем открыть ранее сохраненный, удалить другую половинку и тоже сохранить под другим именем.

При удалении надо вспомнить, как можно выделять с помощью мыши и удалять. На рисунке (рис 36) видно, что поверхность оказалась вывернутой — серого цвета. Развернем ее, нужно кликнуть на ней ПКМ и выбрать Reverse Faces. Если произошла какая-то ошибка, можно ее исправить: Поверхности (грани) можно «закрыть», просто проведя линию от одного угла или ребра к другому. Окружности можно «закрыть» построением хорды и выдавить заново.

Теперь сохраним «половинку» под другим именем, откроем «целый» объект и снова удалим лишнее (рис 37).

Внимательно осмотрим, увеличив масштаб, нет ли каких-нибудь недозакрытых поверхностей. Видим, что есть (рис 38). Таких маленьких незакрытых уголка 4 штуки, расположенных симметрично. Закроем их просто — проведем вдоль одной стороны треугольника линию.

Теперь нужно уменьшить объект в 10 раз. Для этого:

• выделим весь объект Edit – Select All

• Выберем инструмент «Масштабирование»

• возьмем куб выделения за уголок и потянем по диагонали в сторону уменьшения

• введем с клавиатуры значение коэффициента 0,1. Объект уменьшится в 10 раз (рис 39).

Теперь можно нажать пробел, сохранить проект и экспортировать файл в STL. Вторая деталь тоже готова.

Во второй части статьи рассмотрим создание коробки под плату Arduino.